Phone: (860) 946-0698Hours: 11 AM to 7 PM Eastern | Monday - Friday
Search
All Categories
    Menu Close

    PSP Twin-L Download

    Manufacturer: PSP Audioware
    Dual algorithm classic limiter
    SKU: 1035-1218
    $99.00 excl tax
    i h
    Delivery date: 7 to 10 Days

    PSP Twin-L is a dual algorithm classic limiter. The aim of this plug-in is to provide a wide variety of shaping options. The plug-in is able to emulate the main features of two types of limiter: VCA-limiters, which is a modern type of analog limiter, and Opto-limiters which are vintage optical limiters. Keep in mind, however, that PSP Twin-L’s limiting algorithms are not intended to emulate any specific hardware but rather to bring the capabilities of both types into a versatile plug-in. It’s also worth mentioning that the PSP Twin-L is part of our series Zero Latency Processing plug-ins; no additional latency is critical in many situations such as live monitoring and managing automation.

    Minimum system requirements:

    In order  to run a plug-in in 30 day demo mode  or activate the plug-in, you need an iLok user ID which you can create for free at www.ilok.com, and you need to install the free iLok License Manager application. A hardware USB iLok dongle is NOT required, however it is optional.

    PC

    VST3

        • Windows x32 or x64 (7, 8 or 10)
        • VST3 compatible application

    VST

        • Windows x32 or x64 (Vista, 7, 8 or 10)
        • VST 2.4 compatible application

    RTAS

        • Windows x32 or x64 (XP Service Pack 2, Vista, 7 or 10)
        • ProTools 8.0.0 (or later)

    AAX

        • Windows x32 or x64 (XP Service Pack 2, Vista, 7 or 10)
        • Pro Tools 10, 11, 12 or Pro Tools HD 10, 11, 12 or Pro Tools 2018

    All DAWs

    • Up to date iLok License Manager application installed

    Mac

    AudioUnit

        • Mac OSX 10.8 - 10.15 or later
        • 32 or 64-bit compatible host application

    VST

        • Mac OSX 10.8 - 10.15 or later
        • 32 or 64-bit VST 2.4 compatible host application

    VST3

        • Mac OSX 10.8 - 10.15 or later
        • 32 or 64-bit VST 3 compatible host application

    RTAS

        • Mac OSX 10.8, 10.9, 10.10 or 10.11
        • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

    AAX

        • Mac OSX 10.8 - 10.15 or later
        • Pro Tools 10, 11, 12 or Pro Tools HD 10, 11, 12 or Pro Tools 2018

    All DAWs

    • Up to date iLok License Manager application installed