Phone: (860) 946-0698Hours: 11 AM to 7 PM Eastern | Monday - Friday
Search
All Categories
    Menu Close

    PSP oldiTimerMB Download

    Manufacturer: PSP Audioware
    Vintage style multiband compressor
    SKU: 1035-1222
    $199.00 excl tax
    i h
    Delivery date: 7 to 10 Days

    PSP oldTimerMB is a vintage-style multi-band compressor designed for demanding track processing, buss and mix compression, and mastering. (VST, VST3, AudioUnit, AAX and RTAS plug-in) Our aim in developing this plug-in was to design a high end multi-band processor based on the algorithm from our best-selling PSP oldTimer compressor. The result is a musical and warm sounding processor with a range of controls making it a vital tool for virtually any kind of music. Switchable and adjustable output valve emulation give's you a choice of additional color to the sound. Thank you, and please enjoy the versatility and quality of PSP oldTimerMB!

    Minimum system requirements:

    In order  to run PSP InfiniStrip in 30-day trail mode or activate it, you need an iLok user ID which you can create for free at www.ilok.com, and you need to install the free iLok License Manager application. A hardware USB iLok dongle is NOT required, however it is optional. You can activate the license in 3 separate locations, each of which can be either a computer or an iLok dongle (2nd generation or above). You can move these licenses at any time using PACE's iLok License Manager software.


    PC

    VST3

        • Windows x32 or x64 (7, 8 or 10)
        • VST3 compatible application

    VST

        • Windows x32 or x64 (7, 8 or 10)
        • VST 2.4 compatible application

    RTAS

        • Windows x32 or x64 (7,8 or 10)
        • ProTools 8.0.0 (or later)

    AAX

        • Windows x32 or x64 (7,8 or 10)
        • Pro Tools 10, 11, 12 or ProTools HD 10, 11, 12 or ProTools Ultimate

    All DAWs

    • The latest iLok License Manager application installed

    Mac

    AudioUnit

        • Mac OSX 10.8 - 10.15 or later
        • 32 or 64-bit compatible host application

    VST

        • Mac OSX 10.8 - 10.15 or later
        • 32 or 64-bit VST 2.4 compatible host application

    VST3

        • Mac OSX 10.8 - 10.15 or later
        • 32 or 64-bit VST 3 compatible host application

    RTAS

        • Mac OSX 10.8, 10.9, 10.10 or 10.11
        • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

    AAX

        • Mac OSX 10.8 - 10.15 or later
        • ProTools 10, 11, 12 or ProTools HD 10, 11, 12 or ProTools Ultimate

    All DAWs

    • Up to date iLok License Manager application installed