Phone: (860) 946-0698Hours: 11 AM to 7 PM Eastern | Monday - Friday
Search
All Categories
    Menu Close

    PSP 2445 EMT Download

    Manufacturer: PSP Audioware
    Vintage reverb processor
    SKU: 1035-1193
    $149.00 excl tax
    i h
    Delivery date: 7 to 10 Days

    PSP 2445 EMT is a reverb processor plug-in (VST, AAX and RTAS for Windows; AudioUnit, VST, AAX and RTAS for Mac OSX) inspired by two legendary early digital age reverberators: the EMT® 244 and the EMT® 245. PSP thoroughly researched how to bring the specific features of those simple, yet very musical sounding reverbs to life as a plug-in. We then improved from the originals with a handy set of parameters to control details of the sound and mix the reverb not available in the original hardware. The PSP 2445 is capable of processing using one selected engine or both of them simultaneously.

    The reverb algorithms implemented in PSP 2445 are based on original algorithms designed by Dr. Barry Blesser (one of the grandfathers of the digital audio revolution). Thanks to Barry’s extensive consultation and support our algorithms sound as good as the originals and plug-in could be officially endorsed by EMT Studiotechnik GmbH.

    Minimum system requirements:

    In order  to run a plug-in in 30 day demo mode  or activate the plug-in, you need an iLok user ID which you can create for free at https://www.ilok.com/, and you need to install the free iLok License Manager application. A hardware USB iLok dongle is NOT required, however it is optional.

    PC

    VST

    • Windows 7, 8 or 10
    • VST 2.4 compatible application
    • Up to date (at least version 3.1.7) iLok License Manager application installed

    RTAS

    • Windows 7, 8 or 10
    • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)
    • Up to date (at least version 3.1.7) iLok License Manager application installed

    AAX

    • Windows 7, 8 or 10
    • Pro Tools 10, 11, 12 (or later)
    • Up to date (at least version 3.1.7) iLok License Manager application installed

    Mac (intel)

    AudioUnit

    • Mac OSX 10.8 - 10.12 or later
    • 32 or 64-bit host application capable of running AudioUnit plug-ins with Cocoa view
    • Up to date (at least version 3.1.7) iLok License Manager application installed

    VST

    • Mac OSX 10.8 - 10.12 or later
    • 32 or 64-bit VST 2.4 compatible host application
    • Up to date (at least version 3.1.7) iLok License Manager application installed

    RTAS

    • Mac OSX 10.8 - 10.12 or later
    • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)
    • Up to date (at least version 3.1.7) iLok License Manager application installed

    AAX

    • Mac OSX 10.8 - 10.12 or later
    • Pro Tools 10,11,12 or later
    • Up to date (at least version 3.1.7) iLok License Manager application installed